Text Size

  • Increase
  • Decrease
  • Normal

Current Size: 100%

IT Requirements for NCHPP Chats

The software we use for chats, Anymeeting, requires attendees to make the below system requirements; if you are unsure about these requirements, please forward this information to your IT department.

End User Requirements:

IMPORTANT: Upgrade your browser!  If you plan to join the chat online, please make sure your computer is ready and that you have the most current web browser as follows.

Browsers

  • Google Chrome (Preferred): Version 60 or higher
  • Mozilla Firefox: Version 55 or higher
  • Internet Explorer (Version 11 or higher) – Flash Player is required also see below
  • Edge: Version 40 or higher (15 or higher for HTML version)
  • Safari: Version 10 or higher 

Plugins

  • If using Internet Explorer Adobe Flash Player is required – make sure the latest version is installed: https://get.adobe.com/flashplayer/
  • Disable your browser's pop-up blocker for the duration of the chat.

 

System Requirement Details